Beschreibung der Benutzeroberfläche von Bandwidth Monitor
Das Hauptfenster des Programms enthält das Hauptmenü, die Symbolleiste, die Liste der Hosts und Sensoren, die Navigationsleiste, die Informationsleiste und die Statusleiste.
Hauptmenü
Über das Hauptmenü der Anwendung können Sie alle verfügbaren Funktionen aufrufen.
Das Menü Datei ermöglicht:
2. Verbindung zum Server herstellen (Bandbreitenüberwachungsdienst)
3. Überwachungsdienst starten, stoppen, neu starten
4. Anwendungseinstellungen konfigurieren
5. Anwendung beenden
Das Menü Ansicht ermöglicht:
1. Bandbreitendiagramm anzeigen
2. Verkehrstabelle anzeigen
3. Verkehrs-, Bandbreiten- und Ausfallzeitstatistik anzeigen
4. Dunklen Hintergrund im Diagramm aktivieren/deaktivieren
5. Daten im aktuellen Diagramm ein-/ausblenden
Das Menü Gruppen ermöglicht:
2. Neue Untergruppe hinzufügen
Das Menü Hosts ermöglicht:
2. Hosteigenschaften bearbeiten
3. Host löschen
Das Menü Sensoren ermöglicht:
2. Sensoreigenschaften bearbeiten
5. Sensor aktivieren/deaktivieren
8. Abfrage ausgewählter Sensoren erzwingen
9. Sensorliste aktualisieren
Das Menü Protokolle ermöglicht:
1. Alarmprotokoll anzeigen
2. Windows-Ereignisprotokoll anzeigen
Das Menü Hilfe ermöglicht:
1. Diese Hilfedatei öffnen (Inhalt)
2. Informationen zur Anwendung anzeigen
3. Weitere hilfreiche Informationen zur Anwendung abrufen
Symbolleiste
Die Symbolleiste enthält Schaltflächen für den Schnellzugriff auf die am häufigsten genutzten Funktionen der Anwendung.
Liste der zu überwachenden Hosts und Sensoren
Die Überwachungsliste enthält Hosts und Sensoren, die in Gruppen (Ordnern) baumartig organisiert sind. Für jeden Host können Sie eine beliebige Anzahl von Verkehrssensoren konfigurieren. Wählen Sie einen bestimmten Host im Baum aus, um die zugehörigen Sensoren anzuzeigen. Wenn eine Gruppe ausgewählt ist, zeigt die Sensorliste alle Sensoren der Hosts in dieser Gruppe an.
Informationsleiste
Die Informationsleiste zeigt alle verfügbaren Informationen zu den im Baum ausgewählten Sensoren an.
Auf der Registerkarte Diagramm wird das Bandbreitengeschwindigkeitsdiagramm angezeigt.
Auf der Registerkarte Tabelle werden die Sensorzusammenfassungsinformationen angezeigt:
- Hostadresse, die vom Sensor überwacht wird
- Sensorname
- Physische (MAC-)Adresse der überwachten Netzwerkschnittstelle
- Sensortyp
- Aktueller eingehender Verkehr (Volumen, Geschwindigkeit)
- Aktueller ausgehender Verkehr (Volumen, Geschwindigkeit)
- Datum und Uhrzeit der letzten Aktualisierung
- Zustand (aktiviert/deaktiviert)
- Status oder letzte Fehlermeldung
- Abfrageintervall
- Alarmstatus
- Beschreibung
Auf der Registerkarte Statistik werden die Sensorstatistikinformationen für einen festgelegten Zeitraum angezeigt (Unterregisterkarte Gesamt):
- Durchschnittsgeschwindigkeit des eingehenden und ausgehenden Verkehrs
- Maximalgeschwindigkeit des eingehenden und ausgehenden Verkehrs
- Gesamtvolumen des gesendeten und empfangenen Verkehrs
- Anzahl der Abfragefehler
- Gesamte Ausfallzeit
- Anzahl der Unterbrechungen während der Verkehrsüberwachung (wenn das Programm nicht lief)
- Gesamtdateigröße der Statistikdatenbank
Die Registerkarte Statistik enthält außerdem die folgenden Unterregisterkarten: Geschwindigkeits-, Volumen- und Ausfallzeitdiagramme:
- Geschwindigkeit des eingehenden und ausgehenden Verkehrs (Bandbreite) für den festgelegten Zeitraum
- Verkehrsbandbreite (Geschwindigkeit) und Volumen nach Wochentagen
- Ausfallzeit für den Sensor (oder die Schnittstelle) für den festgelegten Zeitraum
